您的位置:网站首页 > 行业资讯 > 行业动态 > 正文

华为设备交换机、路由器常用命令合辑

  2016-01-21 01:46  中国润滑油信息网
华为设备交换机、路由器常用命令合辑

rule [normal|special]{permit|deny} [source source-addr source-wildcard|any]

例:

[Quidway]acl 10

[Quidway-acl-10]rule normal permit source 10.0.0.0 0.0.0.255

[Quidway-acl-10]rule normal deny source any

拓展拜访操控列表设置设备摆设指令

设置设备摆设TCP/UDP协议的拓展拜访列表:

rule {normal|special}{permit|deny}{tcp|udp}source {|any}destination |any}

[operate]

设置设备摆设ICMP协议的拓展拜访列表:

rule {normal|special}{permit|deny}icmp source {|any]destination {|any]

[icmp-code] [logging]

拓展拜访操控列表操作符的意义

equal portnumber;即是

greater-than portnumber;大年夜于

less-than portnumber;小于

not-equal portnumber;不等

range portnumber1 portnumber2;区间

拓展拜访操控列表举例

[Quidway]acl 101

[Quidway-acl-101]rule deny souce any destination any

[Quidway-acl-101]rule permit icmp source any destination any icmp-type echo

[Quidway-acl-101]rule permit icmp source any destination any icmp-type echo-reply

[Quidway]acl 102

[Quidway-acl-102]rule permit ip source 10.0.0.1 0.0.0.0 destination 202.0.0.1 0.0.0.0

[Quidway-acl-102]rule deny ip source any destination any

[Quidway]acl 103

[Quidway-acl-103]rule permit tcp source any destination 10.0.0.1 0.0.0.0 destination-port equal ftp

[Quidway-acl-103]rule permit tcp source any destination 10.0.0.2 0.0.0.0 destination-port equal www

[Quidway]firewall enable

[Quidway]firewall default permit|deny

[Quidway]int e0

[Quidway-Ethernet0]firewall packet-filter 101 inbound|outbound

地址改换设置设备摆设举例

[Quidway]firewall enable

[Quidway]firewall default permit

[Quidway]acl 101;内部指定主性能够进入e0

[Quidway-acl-101]rule deny ip source any destination any

[Quidway-acl-101]rule permit ip source 129.38.1.1 0 destination any

[Quidway-acl-101]rule permit ip source 129.38.1.2 0 destination any

[Quidway-acl-101]rule permit ip source 129.38.1.3 0 destination any

[Quidway-acl-101]rule permit ip source 129.38.1.4 0 destination any

[Quidway-acl-101]quit

[Quidway]int e0

[Quidway-Ethernet0]firewall packet-filter 101 inbound

[Quidway]acl 102;外部特定主机和大年夜于1024端口的数据包准许进入S0

[Quidway-acl-102]rule deny ip source any destination any

[Quidway-acl-102]rule permit tcp source 202.39.2.3 0 destination 202.38.160.1 0

[Quidway-acl-102]rule permit tcp source any destination 202.38.160.1 0 destination-port great-than

1024

[Quidway-acl-102]quit

[Quidway]int s0

[Quidway-Serial0]firewall packet-filter 102 inbound;设202.38.160.1是路由器出口IP

交流机指令

~~~~~~~~~~

[Quidway]dis cur;显现当前设置设备摆设

[Quidway]display current-configuration;显现当前设置设备摆设

[Quidway]display interfaces;显现接口信息

[Quidway]display vlan all;显现路由信息

[Quidway]display version;显现版别信息

[Quidway]super password;修正特权用户暗码

[Quidway]sysname;交流机命名

[Quidway]interface ethernet 0/1;进入接口视图

[Quidway]interface vlan x;进入接口视图

[Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0;设置设备摆设VLAN的IP地址

[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2;静态路由=网关

[Quidway]rip;三层交流支撑

[Quidway]local-user ftp

[Quidway]user-interface vty 0 4;进入虚拟终端

[S3026-ui-vty0-4]authentication-mode password;设置口令形式

[S3026-ui-vty0-4]set authentication-mode password simple 222 ;设置口令

[S3026-ui-vty0-4]user privilege level 3;用户等级

[Quidway]interface ethernet 0/1;进入端口形式

[Quidway]int e0/1;进入端口形式

[Quidway-Ethernet0/1]duplex {half|full|auto};设置设备摆设端口功课状况

[Quidway-Ethernet0/1]speed {10|100|auto};设置设备摆设端口功课速度

华为设备交换机、路由器常用命令合辑

[Quidway-Ethernet0/1]flow-control;设置设备摆设端口流控

[Quidway-Ethernet0/1]mdi {across|auto|normaltb通宝游戏客户端};设置设备摆设端口平接扭接

[Quidway-Ethernet0/1]port link-type {trunk|access|hybrid} ;设置端口功课形式

[Quidway-Ethernet0/1]port access vlan 3;当前端口加入到VLAN

[Quidway-Ethernet0/2]port trunk permit vlan {ID|All};设trunk准许的VLAN

[Quidway-Ethernet0/3]port trunk pvid vlan 3;设置trunk端口的PVID

[Quidway-Ethernet0/1]undo shutdown;激活端口

[Quidway-Ethernet0/1]shutdown;封闭端口

[Quidway-Ethernet0/1]quit;回来

[Quidway]vlan 3;创立VLAN

[Quidway-vlan3]port ethernet 0/1;在VLAN中添加端口

[Quidway-vlan3]port e0/1;简写措施

[Quidway-vlan3]port ethernet 0/1 to ethernet 0/4;在VLAN中添加端口

[Quidway-vlan3]port e0/1 to e0/4;简写措施

[Quidway]monitor-port;指定镜像端口

[Quidway]port mirror;指定被镜像端口

[Quidway]port mirror int_list observing-port int_type int_num ;指定镜像和被镜像

[Quidway]description string ;指定VLAN描画字符

[Quidway]description;删去VLAN描画字符

[Quidway]display vlan [vlan_id];反省VLAN设置

[Quidway]stp {enable|disable};设置天生树,默许封闭

[Quidway]stp priority 4096;设置交流机的优先级

[Quidway]stp root {primary|secondary};设置为根或根的备份

[Quidway-Ethernet0/1]stp cost 200;设置交流机端口的花费

[Quidway]link-aggregation e0/1 to e0/4 ingress|both ; 端口的聚合

[Quidway]undo link-aggregation e0/1|all; 始端口为通道号

[SwitchA-vlanx]isolate-user-vlan enable;设置主vlan

[SwitchA]isolate-user-vlansecondary;设置主vlan包孕的子vlan

[Quidway-Ethernet0/2]port hybrid pvid vlan;设置vlan的pvid

[Quidway-Ethernet0/2]port hybrid pvid;删去vlan的pvid

[Quidway-Ethernet0/2]port hybrid vlan vlan_id_list untagged;设置无标识的vlan

要是包的vlan id与PVId合营,则去掉落vlan信息. 默许PVID=1

以是设置PVID为所属vlan id, 设置能够互通的vlan为untagged.

----------------------------------------

路由器指令

~~~~~~~~~~

[Quidway]display version;显现版别信息

[Quidway]display current-configuration;显现当前设置设备摆设

[Quidway]display interfaces;显现接口信息

[Quidway]display ip route;显现路由信息

[Quidway]sysname aabbcc;变动主机名

[Quidway]super passwrod ;设置口令

[Quidway]interface serial0;进入接口

[Quidway-serial0]ip address;设置设备摆设端口IP地址

[Quidway-serial0]undo shutdown ;激活端口

[Quidway]link-protocol hdlc ;绑定hdlc协议

[Quidway]user-interface vty 0 4

[Quidway-ui-vty0-4]authentication-mode password

[Quidway-ui-vty0-4]set authentication-mode password simple 222

[Quidway-ui-vty0-4]user privilege level 3

[Quidway-ui-vty0-4]quit

[Quidway]debugging hdlc all serial0;显现统统信息

[Quidway]debugging hdlc event serial0;调试工作信息

[Quidway]debugging hdlc packet serial0;显现包的信息

静态路由:

[Quidway]ip route-static {interface number|nexthop}[value][reject|blackhole]

例如:

[Quidway]ip route-static 129.1.0.0 16 10.0.0.2

[Quidway]ip route-static 129.1.0.0 255.255.0.0 10.0.0.2

[Quidway]ip route-static 129.1.0.0 16 Serial 2

[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.0.0.2

动态路由:

[Quidway]rip;设置动态路由

[Quidway]rip work;设置功课准许

[Quidway]rip input;设置入口准许

[Quidway]rip output;设置出口准许

[Quidway-rip]network 1.0.0.0;设置交流路由收集

[Quidway-rip]network all;设置与统统收集交流

[Quidway-rip]peer ip-address;

[Quidway-rip]summary;路由聚合

[Quidway]rip version 1;设置功课在版别1

[Quidway]rip version 2 multicast;设版别2,多播措施

[Quidway-Ethernet0]rip split-horizon;水中分隔

[Quidway]router id A.B.C.D;设置设备摆设路由器的ID

[Quidway]ospf enable;发动OSPF协议

[Quidway-ospf]import-route direct;引入直联路由

[Quidway-Serial0]ospf enable area;设置设备摆设OSPF区域

规范拜访列表指令格局如下:

acl[match-order config|auto];默许前者序次匹配

[Quidway-Serial0]nat outbound 101 interfa骰宝游戏机ce;是Easy ip,将acl 101准许的IP从本接口出时改换源地址

内部效劳器地址改换设置设备摆设指令(静态nat):

nat server global[port] insideport [protocol];global_port不写时运用inside_port

[Quidway-Serial0]nat server global 202.38.160.1 inside 129.38.1.1 ftp tcp

[Quidway-Serial0]nat server global 202.38.160.1 inside 129.38.1.2 telnet tcp

[Quidway-Serial0]nat server global 202.38.160.1 inside 129.38.1.3 www tcp

设有公网IP:202.38.160.101~202.38.160.103 能够运用;对外拜访(原例题)

[Quidway]nat address-group 202.38.160.101 202.38.160.103 pool1;建登时址池

[Quidway]acl 1

[Quidway-acl-1]rule permit source 10.110.10.0 0.0.0.255;指定准许的内部收集

[Quidway-acl-1]rule deny source any

[Quidway-acl-1]int serial 0

[Quidway-Serial0]nat outbound 1 address-group pool1;在s0口从地址池掏出IP对外拜访

[Quidway-Serial0]nat server global 202.38.160.101 inside 10.110.10.1 ftp tcp

[Quidway-Serial0]nat server global 202.38.160.102 inside 10.110.10.2 www tcp

[Quidway-Serial0]nat server global 202.38.160.102 8080 inside 10.110.10.3 www tcp

[Quidway-Serial0]nat server global 202.38.160.103 inside 10.110.10.4 smtp udp

PPP设置:

[Quidway-s0]link-protocol ppp;默许的协议

PPP验证:

主验方:pap|chap

[Quidway]local-user q2 password {simple|cipher} hello;路由器1

[Quidway]interface serial 0

[Quidway-serial0]ppp authentication-mode {pap|chap}

[Quidway-serial0]ppp chap user q1;pap时,没有此句

pap被验方:

[Quidway]interface serial 0;路由器2

[Quidway-serial0]ppp pap local-user q2 password {simple|cipher} hello

chap被验方:

[Quidway]interface serial 0;路由器2

[Quidway-serial0]ppp chap user q2;自个路由器名

[Quidway-serial0]local-user q1 password {simple|cipher} hello ;对方路由器名

帧中继frame-relay(二分册6-61)

[q1]fr switching

[q1]int s1

[q1-Serial1]ip address 192.168.34.51 255.255.255.0

[q1-Serial1]link-protocol fr;封装帧中继协议

[q1-Serial1]fr interface-type dce

[q1-Serial1]fr dlci 100

[q1-Serial1]fr inarp

[q1-Serial1]fr map ip 192.168.34.52 dlci 100

[q2]int s1

[q2-Serial1]ip address 192.168.34.52 255.255.255.0

[q2-Serial1]link-protocol fr

[q2-Serial1]fr interface-type dte

[q2-Serial1]fr dlci 100

[q2-Serial1]fr inarp

[q2-Serial1]fr map ip 192.168.34.51 dlci 100

帧中继监测

[q1]display fr lmi-info[]interface type number]

[q1]display fr map

[q1]display fr pvc-info[serial interface-number][dlci dlci-number]

[q1]display fr dlci-switch

[q1]display fr interface

[q1]reset fr inarp-info

[q1]debugging fr all[interface type number]

[q1]debugging fr arp[interface type number]

[q1]debugging fr event[interface type number]

[q1]debugging fr lmi[interface type number]

发动ftp效劳:

[Quidway]local-user ftp password {simple|cipher} aaa service-type ftp

[Quidway]ftp server enable

  本文系中国润滑油信息网(www.sinolub.com)原创作品,若需转载务必以超链接的形式注明出处,转载时严禁任何有悖原文的文字修改;本网有权对所有侵权行为进行责任追究。

分享到: QQ空间 新浪微博 人人网 开心网 腾讯微博 更多

相关新闻

友情提醒

本信息真实性未经中国润滑油信息网证实,仅供您参考。未经许可,请勿转载。已经本网授权使用的,应在授权范围内使用,并注明“来源:中国润滑油信息网”。

本网部分文章转载自其它媒体,转载目的在于传递更多行业信息,并不代表本网赞同其观点和对其真实性负责。在本网论坛上发表言论者,文责自负,本网有权在网站内转载或引用,论坛的言论不代表本网观点。本网所提供的信息,如需使用,请与原作者联系,版权归原作者所有。如果涉及版权需要同本网联系的,请在15日内进行。

官方微博

热点招商

奥吉星润滑油全国招商

奥吉星润滑油(天泰集团化工控股有限公司 股票代码:GTS)是由天泰控股的专业润滑油生产企业。 全国招商热线:400-0635-789

Gulf海湾石油面向全国招商

海湾石油(中国)有限公司是Gulf Oil International 在国内的唯一子公司。 现诚招经销商。 招商热线:0535-2161171

埃尼润滑油面向全国招商

埃尼是一家综合性能源企业,业务遍及83个国家,拥有84,000名员工,从事石油和天然气勘探、生产、运输、转化和营销活动,业务涉及化工、油田服务、建筑和工程领域。

关于我们|本网动态|广告服务|联系方式|免责声明|版权信息|法律顾问
CopyRight©2015-2016 Sinolub.Com All Rights Reserved 九鼎公司 版权所有
《中华人民共和国增值电信业务经营许可证》编号:粤B2-20050302
服务热线:0754-88650988 在线服务QQ:619128006 润滑油商机信息群:③:50693127 ④:65958932